Author Topic: The 'new' icon no longer disappears after reading topic  (Read 1486 times)

TRex

  • Glossologian
  • **
  • Posts: 1659
  • ~50 miles from Chicago, in the Corn (maize) Belt
    • View Profile
The 'new' icon no longer disappears after reading topic
« on: May 17, 2018, 09:55:31 AM »
This started recently. Previously, changing to a different puzzle or changing to a different day would refresh the 'Forum Latest' section. It no longer does. Only manually refreshing the 'Forum Latest' or refreshing the entire page works.

The same thing also applies when new topics are added changing a puzzle doesn't update the Forum section.
« Last Edit: May 17, 2018, 09:57:12 AM by TRex »

Valerie

  • Word-meister
  • ****
  • Posts: 164
  • Blue Mountains, Australia
    • View Profile
Re: The 'new' icon no longer disappears after reading topic
« Reply #1 on: May 17, 2018, 10:30:16 AM »
Yes, I've noticed this too, TRex.
I'll sleep in my next life

blackrockrose

  • Word-meister
  • ****
  • Posts: 171
  • Muswellbrook, Australia
    • View Profile
    • Rosetta Writes
Re: The 'new' icon no longer disappears after reading topic
« Reply #2 on: May 17, 2018, 10:57:42 AM »
Thirded.

ensiform

  • Paronomaniac
  • ******
  • Posts: 444
    • View Profile
Re: The 'new' icon no longer disappears after reading topic
« Reply #3 on: May 17, 2018, 10:59:43 AM »
It disappears for me.  Using Firefox on a Mac.

Alan W

  • Administrator
  • Eulexic
  • *****
  • Posts: 3948
  • Melbourne, Australia
    • View Profile
    • Email
Re: The 'new' icon no longer disappears after reading topic
« Reply #4 on: May 17, 2018, 02:11:01 PM »
Well spotted, people. This is deliberate, to try to limit the load on the system at peak times, just after a new puzzle has started.

The heavy load at these times has been causing errors such as the one yelnats captured in a screenshot last month, with a "Resource limit is reached" error. Most of these errors are invisible to the player, but can interfere with the storage of playing details. Hence the risk of "lost words".

One thing that was contributing to the load was forum refresh calls. The player navigates to Chi - one refresh. They switch puzzle types - another refresh. They go back to the previous puzzle to check the solution - another refresh. They go back to today's puzzle to start playing - another refresh. The forum data has been retrieved 4 times in the space of a few seconds.

So currently the Forum Latest contents are updated only when you arrive at the website or sign in, and when you click on the refresh icon (or reload the whole page - but please don't do that: it just adds to the problem).

What I can probably do is revert to the previous behaviour except during the period just after a daily puzzle has opened - say the first 15 minutes. In fact most of the overload problems seem to happen in the first 10 seconds or so!

This issue is also behind a change to the retrieval of scoreboard details. This now may not happen until you start playing a puzzle, or manually refresh. (Briefly this applied to closed puzzles, which caused the problems Les reported recently, somewhere or other on the forum, but I can't be bothered looking for it to provide a link.)
Alan Walker
Creator of Lexigame websites

Les303

  • Guest
Re: The 'new' icon no longer disappears after reading topic
« Reply #5 on: May 17, 2018, 02:58:54 PM »
I have to confess that I was on those players who, when first logging in would haphazardly jump from puzzle to puzzle both previous & current until I settled in to actually start playing, I had no idea that was contributing to a strain on the system so I will be much more selective in the future.

I am also at a loss as to exactly where I posted my " retrieval " issue, without creating the appropriate new topic, I just cannot imagine in which thread I might have chosen to make the post.

Alan W

  • Administrator
  • Eulexic
  • *****
  • Posts: 3948
  • Melbourne, Australia
    • View Profile
    • Email
Re: The 'new' icon no longer disappears after reading topic
« Reply #6 on: May 17, 2018, 05:01:19 PM »
I'm not suggesting for a moment that anybody should feel constrained in how they use the site. It's my job to make sure the site can handle whatever pattern of usage is happening.
Alan Walker
Creator of Lexigame websites

Les303

  • Guest
Re: The 'new' icon no longer disappears after reading topic
« Reply #7 on: May 17, 2018, 06:03:08 PM »
Is that a challenge ... of course i'm kidding.

I have explained before that Chi was one of my first introductions to the internet & in particular to an interactive website.
If i had not found this site so easy to follow & so user friendly then that would have probably been the end of my foray into the internet. ( You have a lot to answer for Alan )

Seriously though, your site is brilliant, it brings me enormous pleasure & if there is anything that i can do from my end to make your task just a little bit easier, then please let me know.





bobbi

  • Cryptoverbalist
  • *
  • Posts: 855
    • View Profile
Re: The 'new' icon no longer disappears after reading topic
« Reply #8 on: May 19, 2018, 10:46:58 AM »
Seriously though, your site is brilliant, it brings me enormous pleasure & if there is anything that i can do from my end to make your task just a little bit easier, then please let me know.

Fervently seconded!